HEQ5 ojämn tracking speed

Tekniska beskrivningar rörande monteringar, drivning, elektronik etc.
Starsoft
Inlägg: 1486
Blev medlem: 2007-09-20 14:21:00
Ort: Gävle
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav Starsoft » 2017-01-12 14:19:52

Hej

Min nyfikenhet plågade mig så att jag provade min HEQ5 redan idag, någon variation liknande den som syns på videon finns inte med motsvarande uppsättning enligt bifogad bild. Så vitt jag kan se är det samma typ av montering och samma typ av ombyggnad. Möjligen finns minimala ryck i rörelsen ibland men de är så små så det kan lika gärna vara inbillning.

Jag måste fråga igen, är videon en riktig beskrivning av verkligheten, om videon komprimeras i realtid är det normalt att rörelser blir ryckiga genom att datorbelastningen fördelas ojämnt över tid och vissa bildrutor med ett bestämt intervall tar längre tid att komprimera.

Återstår frågan om det är något fel på utrustningen, jag tvivlar på att stegmotorn kan orsaka de här fenomenen men om jag minns rätt är motorerna identiska så det borde vara överkomligt att byta plats på motorerna för att som om fenomenet förändras. Då kan en tänkbar felkälla elimineras.

HEQ5_drive_1.jpg
HEQ5_drive_1.jpg (167.29 KiB) Visad 3106 gånger


Anders
Observatorium v2.0: http://www.hemlin.se/astroweb
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav AstroFriend » 2017-01-12 16:59:30

Video kan vara krångliga saker.

Normalt spelar en videokamera in med 25fps här i Europa. Datorer spelar upp med andra frekvenser, mest vanligt för LCD monitorer är 60fps. Det går inte jämnt upp med 25, det grafikkortet gör då är att antingen lägga till bildrutor eller hoppa över, möjligen kan den dela mitt i bilderna för att få det att stämma, då uppstår sk tearing vid rörelser. Riktigt avancerade grafikkort kan interpolera fram nya rutor och få det rätt men ger mer softade bilder istället. Enklare grafikkort spelar upp det i fel hastighet. Såsom gamla svartvita Chaplin filmer ofta visades. 18fps uppspelades med 25fps utan konvertering.

Bara som en av många förklaringar om att det som ser för ögat att gå jämnt kan bli ryckigt på video.

Nu tror jag den ursprungliga författaren också sa att han såg det för blotta ögat att det går ryckigt.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
ragge
Inlägg: 1318
Blev medlem: 2014-03-23 22:25:03
spamtest: JA
Ort: Uddevalla
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav ragge » 2017-01-12 19:57:05

Videon är helt obehandlad och visar precis det som jag kan se "live".
Jag har testat igen med precis samma resultat. Jag har räknat ut att det går 0,6 sek mellan två helsteg. När jag kollar ljudfilen i ett redigeringsprogram så visar sig att ljudet har samma rytm (0,6 sek). Jag riggade även upp min mobiltelefon, så att den tiltar med RA-motorns rotation, med appen "Androsensor" som kan logga det mesta till csv-format. Valde "gyroscope" med sampling 0,2 sek, in i Excel och där ser man exakt 0,6 sek mellan cyklerna.
Bara för att konstatera att något skumt sker i samma takt som helstegen, men om det sker vid dessa eller mitt i mellan kan jag inte säga utifrån detta.

hbar skrev:...Jag gissar att huvudproblemet är att där är för dålig u-stegs upplösning runt helstegspunkten dvs att motorn är alldeles för stark när polerna ligger mitt för varandra. När den närmar sig eller skall lämna helstegspositionen så finns egentligen inte de sista o första u-stegen utan motorn går direkt/ligger fysiskt kvar i position 0 där den är starkast. Beroende på hur motorn är utformad så går detta bara att kompensera till viss del o det sker genom att kraftigt försvaga den runt 0-läget. Denna kompensation blir belastningsberoende dvs även om man får det nästan perfekt i en rigg så ser det annorlunda ut när motorn sitter i monteringen.

/Håkan

För starka helsteg låter som en rimlig förklaring. Men jag ser inga ryck där visaren stannar till (kolla videoklippet). I stället verkar hastigheten öka mer och mer ju närmare helsteget man kommer, och efter helsteget blir det en seg startsträcka innan hastigheten åter är korrekt.
Jag kan inte kan se någon som helst skillnad på hur det uppför sig med helt obelastad motor eller hårt bromsad (eller tom om jag "skjuter på").
Om nu Anders montering uppför sig annorlunda, kan förklaringen vara olika revisioner på motorerna ?

Starsoft skrev:Återstår frågan om det är något fel på utrustningen, jag tvivlar på att stegmotorn kan orsaka de här fenomenen men om jag minns rätt är motorerna identiska så det borde vara överkomligt att byta plats på motorerna för att som om fenomenet förändras. Då kan en tänkbar felkälla elimineras.
Anders


Hej Anders,
Snällt att du ville testa.
Du har inte möjlighet att lägga ett måttband bakom visaren och filma en snutt så jag kan jämföra ?
Om det visar sig att min montering är unik så får jag väl testa att skifta motorerna, men risken är ju att de båda är likadana. Att det skulle vara något fel på motorn har jag svårt att tro, möjligen att det skiljer på olika tillverkningsserier.

Ragnar
Prylar :HEQ5 Pro "AI" (Arduino Inside) , TS APO 107mm f/6.5, TS Imaging Star 71 f/4.9, Meade 8" LX200 ACF, Nexguider, 2 x moddade Nikon D7000, DslrDashboard (Android)
Starsoft
Inlägg: 1486
Blev medlem: 2007-09-20 14:21:00
Ort: Gävle
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav Starsoft » 2017-01-12 22:00:17

Hej

Du har inte möjlighet att lägga ett måttband bakom visaren och filma en snutt så jag kan jämföra ?

Jag får prova att filma på samma sätt men det blir först till helgen.

Att det skulle vara något fel på motorn har jag svårt att tro

Nej det tror inte jag heller, men jag har svårt att svälja att normala avvikelser i motorns rotation skulle kunna synas så tydligt så jag söker desperat efter andra förklaringar.

Anders
Observatorium v2.0: http://www.hemlin.se/astroweb
hbar
Inlägg: 498
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: HEQ5 ojämn tracking speed

Inläggav hbar » 2017-01-12 22:01:37

En möjlig förklaring är om HEQ5an har olika effektlägen när den kör motorn fort resp trackar. Många färdiga mikrostegs kretsar har möjlighet att ställa max strömmen inom ett stort område eller växla mellan 2 olika strömmätningsmotstånd.

Anledningen till detta är dels för att användaren skall kunna implementera power down mode med håll moment men även att u-stegning blir bättre runt helstegs läget då man minskar strömmen. För max hastighet-belstning vill man ha hög ström men bryr sig inte om u-steg.

Om skillnaden är att Ragnars montering alltid går i högeffektsläge (pga ett fel, hårdvaro eller program version) medan Anders montering går ner i lågeffekt när den trackar. Om ni kan mäta strömförbrukningen när den går olastad så kan man i så fall se om där är någon större skillnad. Se i så fall till så att ra-axeln är helt frikopplad så denna inte belastar motorn.

Ragnar, din beskrivning på hur den går fort in o sen segar ut stämmer bra med detta beteende. Det skulle synas ännu tydligare om motorn gick helt frikopplad (så inte massan i växellådan dämpade ryckigheten).

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
ragge
Inlägg: 1318
Blev medlem: 2014-03-23 22:25:03
spamtest: JA
Ort: Uddevalla
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav ragge » 2017-01-12 22:28:12

Monteringen drar 0,39 A när den står stilla.
När den trackar och även vid slew med valfri hastighet drar den 0,72 A. Det är mätt utan last, och med RA-kopplingen släppt.

Jag kan nämna också att om jag nyper till runt motoraxeln lite med fingrarna när den trackar så ändras inte förloppet såvitt jag kan se. Då kan jag också känna av vibrationerna och rörelsen på axeln att mikrostegen hela tiden roterar axeln utan ryck - det går mjukt och fint.

Anledningen till att jag började undersöka detta var som sagt att jag såg hur en stjärna gungade ytterst lite i riktning RA när jag digitalzoomade in till max (med 1400 mm FL). Den lilla rörelsen kanske i sig inte är så allvarlig, men det skulle kunna vara en förklaring till varför guidekameran ibland har problem i just RA. Periodtider på 0,6 sekunder är ingen lätt match att guida bort - det kan ju i stället generera större fel.

Anders, det är jättebra om du fixar det i helgen - tackar !

Ragnar
Prylar :HEQ5 Pro "AI" (Arduino Inside) , TS APO 107mm f/6.5, TS Imaging Star 71 f/4.9, Meade 8" LX200 ACF, Nexguider, 2 x moddade Nikon D7000, DslrDashboard (Android)
hbar
Inlägg: 498
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: HEQ5 ojämn tracking speed

Inläggav hbar » 2017-01-14 14:21:38

Om du skulle vilja minska vridmomentet vid noll-läget lite så skulle det kunna göras med en dubbelriktad zenerdiod med ett seriemotstånd. Den kopplas in över lindningen under tracking och reducerar strömmen genom motorn när spänningen över lindningen är som störst (vilket borde vara 0-positionen i u-stegs tabellen, halvstegspositionen brukar vara ca 70% och sen går den ner till 0 samtidigt som den andra lindningen går upp till 100%).

För att kunna välja värden behöver du se spänningen över motorn med ett oscilloskop och sen prova med några lämpliga värden. Går ev att få fram genom att koppla in spänningen via en dämpsats till en mikrofoningång men sen behöver du kalibrera signalen så att man vet topp spänningen. Du behöver också mäta vilken likströmsresistans lindningen har.

Skulle du ha ärende neråt Lund så har jag instrument o kan göra det åt dig.

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav AstroFriend » 2017-01-14 16:17:38

Här har ni en tabell som visar hur växlarna och antal mikrosteg skiljer på de olika varianterna på EQ monteringar.

http://eq-mod.sourceforge.net/prerequisites.html

Den verkar dock inte helt korrekt vilket ni ser om ni kontrollräknar.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Starsoft
Inlägg: 1486
Blev medlem: 2007-09-20 14:21:00
Ort: Gävle
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav Starsoft » 2017-01-14 18:15:42

Hej

Då har jag tittat till min HEQ5 igen, konstaterade ett par saker.

Den plåtremsa som jag använde i stället för Ragnars bågfilsblad är ganska tung, jag var tvungen att balansera den så att den sticker ut lika långt åt båda hållen och den kan nog tänkas bidra med ett påtagligt tröghetsmoment och därmed utgöra det svänghjul som föreslogs tidigare. Jag behöver alltså en lättare lösning för att inte fördärva mätningarna, så jag lär nog tills vidare ta tillbaka mitt tidigare påstående att min axel rörde sig utan ryck.

Jag tog också och exporterade en serie bilder från Ragnars video så att jag kunde stega bild för bild i videon, där finns en del intressant information att hämta även om upplösningen var lite dålig, det såg ut som stegen som mest motsvarar 8 u-steg och som minst stod den nog så gott som stilla i några bilder men jag råder den nyfikne att kontrollera själv innan några slutsatser dras. Det skulle ju gå att plotta en graf över avvikelserna och därmed kanske kunna dra någon klok slutsats.

Min närmaste plan är att ställa en liten spegel på drevet och sedan använda en laserpekare och spegla strålen ett par meter bort på väggen så att jag kan få bättre upplösning och ingen svänghjulseffekt, laserpekare har jag men hittar ingen lämplig spegel, jag återkommer.

Anders
Observatorium v2.0: http://www.hemlin.se/astroweb
Användarvisningsbild
ragge
Inlägg: 1318
Blev medlem: 2014-03-23 22:25:03
spamtest: JA
Ort: Uddevalla
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav ragge » 2017-01-14 19:29:02

Håkan,
Om jag fattat rätt så skulle den kretsen du föreslog läggas parallellt över lindningen (en på varje lindning, dvs 2 st) så att den "stjäl" lite ström när spänningen är på topp. Som av en händelse byggde jag igår ihop en rc-krets att användas som probe till en Android oscilloskop-app, via mic-ingången. Har testat att den fungerar men inte kalibrerat mot något. Men jag tvekar inför att koppla på något på kretskortet - det är så väldigt tätt mellan lödpunkterna - och kablarna till motorn måste ju skalas av om jag skall gå på där. Vet inte heller hur kalibreringen skulle ske, för det går ju inte med likström.
Hade jag haft närmare till Lund så hade jag gärna hälsat på - tackar för erbjudandet !

Anders,
Om du tar en spegel + laser så blir det svårt att jämföra med mitt resultat. Men det kanske inte behövs om du ser tydligt hur det uppför sig. Jag tog ett bågfilsblad som tejpades på remhjulet, och förlängde bladet med ett dubbelvikt papper. Visarens längd var c:a 50-55 cm.

Idag skiftade jag plats på de båda motorerna, men det gjorde ingen skillnad.

Ragnar
Prylar :HEQ5 Pro "AI" (Arduino Inside) , TS APO 107mm f/6.5, TS Imaging Star 71 f/4.9, Meade 8" LX200 ACF, Nexguider, 2 x moddade Nikon D7000, DslrDashboard (Android)
Starsoft
Inlägg: 1486
Blev medlem: 2007-09-20 14:21:00
Ort: Gävle
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav Starsoft » 2017-01-16 20:21:35

Hej

Till nästa helg ska jag prova med både bågfilsblad och laser så får vi se vad det ger.

Anders
Observatorium v2.0: http://www.hemlin.se/astroweb
Användarvisningsbild
ragge
Inlägg: 1318
Blev medlem: 2014-03-23 22:25:03
spamtest: JA
Ort: Uddevalla
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav ragge » 2017-01-17 11:16:11

ragge skrev:Håkan,
Om jag fattat rätt så skulle den kretsen du föreslog läggas parallellt över lindningen (en på varje lindning, dvs 2 st) så att den "stjäl" lite ström när spänningen är på topp. Som av en händelse byggde jag igår ihop en rc-krets att användas som probe till en Android oscilloskop-app, via mic-ingången. Har testat att den fungerar men inte kalibrerat mot något. Men jag tvekar inför att koppla på något på kretskortet - det är så väldigt tätt mellan lödpunkterna - och kablarna till motorn måste ju skalas av om jag skall gå på där. Vet inte heller hur kalibreringen skulle ske, för det går ju inte med likström.
Hade jag haft närmare till Lund så hade jag gärna hälsat på - tackar för erbjudandet !

Anders,
Om du tar en spegel + laser så blir det svårt att jämföra med mitt resultat. Men det kanske inte behövs om du ser tydligt hur det uppför sig. Jag tog ett bågfilsblad som tejpades på remhjulet, och förlängde bladet med ett dubbelvikt papper. Visarens längd var c:a 50-55 cm.

Idag skiftade jag plats på de båda motorerna, men det gjorde ingen skillnad.

Ragnar


EDIT : Håkan, nu fattar jag kretsen. Först ett seriemotstånd, sedan zenerdioden parallellt över lindningen. Smart ! Tror du att man kan mäta spänningen med AC multimeter i st för oscilloskop ? Det bör ju gå att räkna ut toppspänningen utifrån det som instrumentet visar.
Skall beställa "Grovekablar" (tror att det är den typen av kontakter) så att jag kommer åt att mäta bättre.
Prylar :HEQ5 Pro "AI" (Arduino Inside) , TS APO 107mm f/6.5, TS Imaging Star 71 f/4.9, Meade 8" LX200 ACF, Nexguider, 2 x moddade Nikon D7000, DslrDashboard (Android)
Användarvisningsbild
Tony
Inlägg: 432
Blev medlem: 2015-05-03 13:21:31
spamtest: JA
Ort: Borlänge

Re: HEQ5 ojämn tracking speed

Inläggav Tony » 2017-01-26 08:55:02

Fick ett bra tillfälle att testa Nema17 200 stepps 0,4A.
Den är nu monterad i en bältesväxellåda 36:1 och jag har fäst en laserkollimator på utgående axeln.
Genom att studera hur laserpricken rör sig på väggen så ser jag tydligt rörelsen på motorn. Växellådan går dessutom mycket exakt.

Jag kan konstatera följande: Motorn låter som en stor dieselmotor på tomgång, ett pulserande ljud, ca 1 sek intervall, när den är i stjärnföljarläge.
Spelar ingen roll vilken microstepp jag använder, 1-2-4-8-16-32. Blir bara lite olika ton. När jag slewar den så finns det kvar men blir omöjligt att höra när det går för fort. Intervallet varierar beroende på växelutförandet, i mitt aktuella fall blev det ca 0,9 sek.

Jag förmodar att felet är inbyggt i alla steppmotorer, mer eller mindre, men kanske kan minskas med nåt knep?
Är det sista inlägget före mig som är den slutgiltliga lösningen som finns här på forumet?

En pausperiod på ca 1 sek kanske inte spelar så stor roll för stjärnföljningen men jag är lite orolig för min kommande konstruktion där det är en mycket tung massa som ska drivas runt.

-Väntar även på svar från AstroEq där min styrenhet kommer ifrån.
Bilagor
vaxel.gif
vaxel.gif (277.27 KiB) Visad 2966 gånger
GSO 305/1500 mm Messier 150/1200 mm guidetub
kamera/guider/sökare: Orion all in one.Kamera/guider SWO Asi 120MC
Montering: egen tillv. ca 100 kg AstroEQ + EQ-Mod
Fast uppställd i ett obs på hjul. Canon EOS 1200D fullspectrum
Användarvisningsbild
ragge
Inlägg: 1318
Blev medlem: 2014-03-23 22:25:03
spamtest: JA
Ort: Uddevalla
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav ragge » 2017-01-26 12:28:49

Tony skrev:Fick ett bra tillfälle att testa Nema17 200 stepps 0,4A.
Den är nu monterad i en bältesväxellåda 36:1 och jag har fäst en laserkollimator på utgående axeln.
Genom att studera hur laserpricken rör sig på väggen så ser jag tydligt rörelsen på motorn. Växellådan går dessutom mycket exakt.

Jag kan konstatera följande: Motorn låter som en stor dieselmotor på tomgång, ett pulserande ljud, ca 1 sek intervall, när den är i stjärnföljarläge.
Spelar ingen roll vilken microstepp jag använder, 1-2-4-8-16-32. Blir bara lite olika ton. När jag slewar den så finns det kvar men blir omöjligt att höra när det går för fort. Intervallet varierar beroende på växelutförandet, i mitt aktuella fall blev det ca 0,9 sek.

Jag förmodar att felet är inbyggt i alla steppmotorer, mer eller mindre, men kanske kan minskas med nåt knep?
Är det sista inlägget före mig som är den slutgiltliga lösningen som finns här på forumet?

En pausperiod på ca 1 sek kanske inte spelar så stor roll för stjärnföljningen men jag är lite orolig för min kommande konstruktion där det är en mycket tung massa som ska drivas runt.

-Väntar även på svar från AstroEq där min styrenhet kommer ifrån.


Hej Tony,

Du skriver bara att ljudet pulserade med ett visst intervall, men kunde du även verifiera att rörelsen (laserpricken) varierade i hastighet synkront med ljudet ?
Det finns "knep" som jag skrev tidigare : http://www.astro-electronic.de/mikro.htm
I mitt fall är "svajet" så litet att det är försumbart även med 1400 mm fokallängd, om man bara ser till den lilla drift som uppstår. Men det finns en anledning att om möjligt eliminera även detta, och det är att problemet kan förstärkas om guidningen får bekymmer pga översvängningar i reglerförloppet.
Jag har inte gett upp en ev fix enligt Håkans tips, men kommer nog inte göra några större ingrepp under pågående säsong - får bli ett sommarprojekt i så fall.

Den stora massan som skall drivas runt i ditt fall lär inte bli något större bekymmer än på någon annan montering, för jag tycker det verkar som att du har dimensionerat allt i proportion till lasten - och då blir ju situationen likvärdig.

Ragnar
Prylar :HEQ5 Pro "AI" (Arduino Inside) , TS APO 107mm f/6.5, TS Imaging Star 71 f/4.9, Meade 8" LX200 ACF, Nexguider, 2 x moddade Nikon D7000, DslrDashboard (Android)
Användarvisningsbild
mikaelanderlund
Inlägg: 507
Blev medlem: 2008-08-19 20:31:04
Ort: Östra svenstorp
Kontakt:

Re: HEQ5 ojämn tracking speed

Inläggav mikaelanderlund » 2017-01-26 12:56:10

Intressant läsning eftersom jag har ett liknande problem med min CPC1100 Celestron. Jag är ju en inbiten visuell observatör men det hindra mig inte att prova på EEA (Electronically Assisted Astronomy) dvs. video och AP då och då. Jag har även en wedge men ingen guidning. Exponeringar längre än 20-40 sekunder brukar leda till stjärnorna lämnar ojämna streck efter sig (sträck med lite punkter). Egendomligt nog kan jag ibland ha exponeringar på 1 minut utan några problem alls men oftast blir 3 av 5 bilder dåliga med hoppande stjärnor som lämnar ojämna streck efter sig. Varför är visa bilder perfekta med lång exponering utan guidning och andra bilder lämnar långa stjärnspår med kort exonering? Varför kan jag ha en exponering på 60 sekunder ibland och mindre 20 sekunder på andra objekt? Som ni hör har jag mycket lite erfarenhet av AP :)

Återgå till "Monteringar"

Vilka är online

Användare som besöker denna kategori: 12 och 0 gäster